Run as administrator option not working or missing in Windows 11/10

How to Fix Run As Administrator Not Working in Windows 10

How to Run as Administrator using Keyboard Shortcut

If you have pinned an application to the Start Menu or Taskbar, you can easily open it as an administrator using keyboard shortcuts.

Step 1: Select an app or program(ex: Windows PowerShell) to highlight it.

Step 2: Press and hold the Ctrl+Shift keys. Press Enter or click on the app.

Step 3: Release the CTRL + Shift keys. Windows PowerShell(Admin) is popping up.

How to Run as Administrator in Task Manager

Step 1: Open Task Manager in more details view.

Press Win+X, and T keys. If it opens in mini mode, click on More details button.

Step 2: Click on File > Run new task.

Step 3: Type the name of the apps .exe file (ex: cmd) or browse to and select the programs .exe file or shortcut, check the Create this task with administrative privileges box, and click on OK.

If you like, you can quickly run Command Prompt as Administrator using WinX keyboard shortcuts. Here is how to do: Press Windows logo + X shortcut keys and then hit A key on the keyboard.

How to Run as Administrator in File Explorer Ribbon

Step 1: Open the location of application in File Explorer.

Step 2: Select the program or app in question. Then click on the Application Tools Manage tab, and then click on the top half of the Run as administrator button in the ribbon.

2] Clean up Context Menu items

Use one of these Context Menu Editor software to remove unwanted context menu items – especially those whch may have been added in the recent past.

12 Answers 12 Sorted by:

You may be able to use the run as administrator available on the compatibility tab.

One way third party way would be with nircmd. http://www.nirsoft.net/utils/nircmd2.html#elevate

Eg:

for a python script add in the target field:

"C:Users......Python36python.exe" "C:Users......test.py"

For PowerShell script add this in the target:

powershell.exe -command "& C:A path with spacesMyScript.ps1"

(if you want to also pass some args see this)

Dont forget to check the “run as admin” after…

All the glory to Ramesh Srinivasan

It seems as though the “run as administrator” context menu option and/or shortcut checkbox are unavailable for batch files/scripts. This was answered for PowerShell here: How to run script as administrator?

I dont have an answer yet for running a common batch file.

This seems to happen when a shortcut points to an object identifier rather than a directory path.

You can tell if this is the case because the target in the shortcut properties is something like {0AFACED1-E828-11D1-9187-B532F1E9575D} instead of a directory path.

If you want to create a shortcut to something in C:WindowsSystem32, create the shortcut directly off an item in that folder, rather than trying to create it from an existing shortcut on the start menu.

The fix is to create a shortcut to the executable that needs to be run as admin (if you want to workaround the ugly code for invoking the UAC prompt). After creating the new shortcut, right-click on it and select Properties, then click the Shortcut tab, then the Advanced… button and finally check the Run as Administrator checkbox.

This seems to happen with file types windows doesnt recognize/trust. But I just found a simple solution for this.

Make a shortcut to cmd.exe (c:windowssystem32cmd.exe), and replace the Target field with this

Now you should be able to enable the “Run as administrator” on the Advanced tab

Caveats:

  • On windows 10, running as administrator seems to have a different set of network drives, try to use absolute UNC paths rather than mapped drives
  • If you need to pass parameters please check here for some documentation for the Start command
  • Why do we use Start instead of just opening it with cmd.exe?

  • If you just run the file using a shortcut to cmd.exe /c c:pathtoyour.file, youre stuck with an empty black window open so long as your program is running
  • How does using Start work around this?

  • It starts a cmd instance with the /c flag which closes it after its command finishes running
  • It then runs Start which is a native command in cmd.exe that opens a “program” in a new window
  • The way the Start command works if its not an executable the launch gets passed up to Windows, which then opens it using the associated program for that file type
  • Once the launch is started, the Start command ends which then lets the cmd.exe window close
  • Go to the properties of shortcut file
  • Click on shortcut tab
  • add “powershell.exe” before the path of file in Target
  • it should look like below:

    powershell.exe -file “H:PowershellMyPoshScript.ps1”

  • Click apply
  • Click advance button
  • Run as administrator now selectable.
  • Check Run as administrator and apply –> OK
  • I had this issues on a Windows Server 2008 R2 SP1 system when running shortcuts to run batch files/VBScripts to sync and eject USB disks, or to shutdown Hyper-V systems in preparation for staff to reboot the server cleanly.

    Found when I right-clicked the icon, selected properties, then selected the Advanced button next to Change Icon. Select the Run As Administrator option then Save. If UAC is enabled, it will still ask for permission to run, but it will now run properly.

    My icon was copied to the quick launch bar. The option to run as administrator was greyed out. So I started again and I deleted the shortcut i had previously tried to set.

    This is how i solved the issue.

    Opened my start menu, found the icon I wanted, properties, open file location. (This opened the file location of the shortcut from my start menu – perfect).

    Now I selected the shortcut icon and copied it.

    I then right click on my quick launch bar, “Open Folder” and pasted a copy of my shortcut there.

    Now I have access to set it to run as administrator.

    This is valid for Windows7 at least.

    I was trying for Control Panel to “Run as admin”, but it was greyed out for a standard user. Solved by opening C:WindowsSystem32, right-clicked on Control and created the shortcut on the desktop. Now this shortcut is available with “Run as administrator” on right-click.

    This is the solution (example for Word 2016, Windows 10)

  • Dont use the regular shortcut
  • Find the main file (for Word 2016 : “C:Program FilesMicrosoft OfficeOffice16WINWORD.EXE”)
  • Make a shortcut with “Send to the desktop as a shortcut”
  • Now you will see that “Always run as an administrator” option is not greyed out.
  • Thanks for contributing an answer to Super User!

  • Please be sure to answer the question. Provide details and share your research!
  • Asking for help, clarification, or responding to other answers.
  • Making statements based on opinion; back them up with references or personal experience.
  • To learn more, see our tips on writing great answers. Draft saved Draft discarded

    https://www.thewindowsclub.com/wp-content/uploads/2022/01/change-account-type.png

    Leave a Comment